FANDOM


  • Hey man...Hopes to not bother...Can u help me with console commands?I have been searching all the web but I cant find the sollution..I have succesfully enabled the console,and when I try to debugspawn something it says :attempt to call a nil value and such shit...


    Thank u for ur time,and feel free to answer this when u will be able...I dont want to be pussy..

      Loading editor
    • So the answer might be that you are not caring about caps SeNsiTiViTy and make sure to write exactly what it says example debugspawn("deerclops") Will not work you have to do it like this DebugSpawn("deerclops") and no spaces. Hope this helps :). Good luck

        Loading editor
    • Also are you typing "DebugSpawn" or "c_spawn" (as it says near the top of  the Console page)? These do different things, so it matters which you are using. DebugSpawn is for Mobs/Objects (structures) while c_spawn is for items.

        Loading editor
    • Actually DebugSpawn can be used for items too, c_spawn is just the one that spawns stacks for you rather than piles of individual items.

      Related question: is there any time the parenthesis we used to put in spawn codes are actually needed? At least on my computer, the quotation marks are the only thing needed. The parenthesis don't hurt, nor do spaces, but they're not needed.

        Loading editor
    • Shoggoth1890 wrote:
      Actually DebugSpawn can be used for items too, c_spawn is just the one that spawns stacks for you rather than piles of individual items.

      Related question: is there any time the parenthesis we used to put in spawn codes are actually needed? At least on my computer, the quotation marks are the only thing needed. The parenthesis don't hurt, nor do spaces, but they're not needed.

      Well it don't work for me if i use spaces. And i have to take the parenthesis if not it won't work. So this is somewhat weird from what i read. I will have to do some testing.

        Loading editor
    • What kind of system are you using?  What kind of keyboard?  Have you tried taking out the quotation marks and only using parenthesis?

        Loading editor
    • So i just tryed to do it without the parenthesis and it works. Same with spaces. I guess it might have been in the new update because in the previous update it didn't work. I use Windows 7 and Norwegian Keyboard. Meaning i have to press "Ø" to open the console.

        Loading editor
    • From what I understand the console works differently for different people in different situations. This may have something to do with updates, but also definately has to do with different languages/keyboards. During my time here we've had many users with console problems, and various solutions (and in one case we couldn't get it to work). Another part of the problem is that Klei doesn't tell you exactly what everything does/doesn't do/is supposed to do, or tell you when then change something.

        Loading editor
    • An anonymous contributor
        Loading editor
Give Kudos to this message
You've given this message Kudos!
See who gave Kudos to this message
Community content is available under CC-BY-SA unless otherwise noted.